[Nur für Profis!] MMS mit dem Nokia N900

Dieses Thema im Forum "Maemo / MeeGo Forum" wurde erstellt von Globus, 5. Jan. 2010.

  1. Globus

    Globus VIP Mitglied

    Registriert seit:
    14. Sep. 2006
    Beiträge:
    123
    Zustimmungen:
    0
    So bevor nun alle herrum experimentieren, dieser Workarround ist nicht mal im Develbereich zu finden, also sowas von PrePrePRE-Alpha, wie es nur geht. Desweiteren soll es sich derzeit um Test-MMS handeln, das heißt über den Provider könnt ihr keine verschicken.

    Derzeit haben es 2 Entwickler geschafft MMS auf das N900 zu bringen, Mohammed Sameer ist damit am weitesten bekommen, war jedoch nicht der 1., der dies zu erst realisiert hat.

    Desweiteren ist dazu zu sagen, dass es auf Kommandozeile beruht, was den derzeitigen Entwicklungsstand auch nochmal unterstreicht.

    Download: http://home.foolab.org/files/mkmms.tgz

    Entpacken mit "tar -xf mkmms.tgz".
    Ausführen mit "./mkmms <to address> /home/mohammed/me.jpg m-send-req.mms subject"

    Und wer Fragen haben sollte, was mit den Befehlen gemeint ist sollte lieber die Finger davon lassen, nur ein gut gemeinter Rat! ;)

    mkmms available. | Mohammed Sameer's
     
  2. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    Also ich habe auch einen weiteren weg gefunden, wie man mit dem n900 mms empfängt, als auch sendet.

    1. Man muss sich über den Programmanager das Program fAPN runterladen
    2. Damit richtet man manuell ein New APN ein.
    3. Ab in die Einstellungen des N900 und dann den vorher eingerichteten APN wählen und bearbeiten.
    4. Hier muss man dann die Daten seines Netzbetreibers eingeben
    5. FMMS runterladen. dies findet ihr unter folgendem link. ich hoffe ich darf den angeben, wenn nicht könnte das ja mal jemand hier hochladen, ich hab ewig gebraucht, den link zu finden, da man sonst nur die debian pakete findet. und die sind für anfänger nicht einfach zu installieren, da kommt immer irgendeine fehlermeldung, dass irgendwelche dateien fehlen
    http://repository.maemo.org/extras-devel/dists/fremantle/install/fmms.install
    Nach der Installation könnt ihr das Programm starten und konfigurieren. Die gängigsten Netzbetreiberdaten habe ich mal aufgelistet.

    Eine genauere Beschreibung gibts auch unter
    MMS mit dem N900 (fMMS) MAEMO.CH – Nokia N900

    Bei mir hats geklappt. Sobald ich eine MMS bekomme, kriege ich eine nachricht, dass eine mms gekommen ist
    ACHTUNG. Herunterladen tue ich die MMS mit dem normalen Internetprofil, womit man auch surft. Also Einwählen über die Uhr oben, dann Verbindungen und euer jeweiliges Provider Profil., dann fMMS starten und die nachricht holen.
    Will man jedoch eine MMS senden, dann wählt man sich über das vorher eingestellte MMS-Profil ein.


    Hier die gängigsten Providereinstellungen. T-Mobile funktioniert. Hab ich probiertl

    Vodafone DE

    (Internetverbindungen)
    * Verbindungsname: Vodafone MMS
    * Verbindungstyp: Packetdaten
    * Name des Zugangspunktes: event.vodafone.de
    * Benutzername:
    * Kennwort:
    (Erweitert)
    * Proxy: Ja
    * HTTP Proxy: 139.7.29.17
    * Portnummer: 80

    (fMMS Configuration)
    * APN: Vodafone MMS
    * MMSC: http://139.7.29.17/servlets/mms
    * Resize Image width: 0
    * Your phonenumber: Handynummer
    Zitat:
    O2 Germany

    * Connection Name: O2 MMS
    * Connection Type: GPRS
    * Access Point Name: internet
    * User Name: (leave blank)
    * Password: (leave blank)
    * Use Proxy: Yes
    * HTTP Proxy: 195.182.114.52
    * Port Number: 8080
    * MMSC: http://10.81.0.7:8002
    * Resize Image: 300
    * Your Phone Number: +49(Your Phone Number)
    o Note: You must use international notation. National notation (using 0 in front of the phone number) will not work. This applies to Your Phone Number and your recipient's phone number.
    Zitat:
    E-Plus Germany

    * Connection Name: E-Plus MMS
    * Connection Type: GPRS
    * Access Point Name: mms.eplus.de
    * User Name: mms
    * Password: eplus
    * Use Proxy: Yes
    * HTTP Proxy: 212.23.97.153
    * Port Number: 5080
    * MMSC: http://mms/eplus
    * Resize Image: 300
    * Your Phone Number: +49(Your Phone Number)
    o Note (copied from O2, not sure if mandatory): You must use international notation. National notation (using 0 in front of the phone number) will not work. This applies to Your Phone Number and your recipient's phone number.
    Zitat:
    T-Mobile DE

    (Internetverbindungen)
    * Verbindungsname: T-Mobile MMS
    * Verbindungstyp: Packetdaten
    * Name des Zugangspunktes: mms.t-d1.de
    * Benutzername: t-mobile
    * Kennwort: mms
    (Erweitert)
    * Proxy: Ja
    * HTTP Proxy: 172.28.23.131
    * Portnummer: 8008

    (fMMS Configuration)
    * APN: T-Mobile MMS
    * MMSC: http://mms.t-mobile.de/servlets/mms
    * Resize Image width: 0 (aber bleibt ja euch überlassen)->hier evtl 500 eintragen. hab ich gemacht, da ich irgendwo gelesen habe, dass 0 nicht funktioniert
    * Your phonenumber: Eben eure Handynummer

    Wenn jemand andere Erfahrungen bezüglich der Betreiber hat, bitte ergänzen
     
    #2 spion83, 13. März 2010
    Zuletzt von einem Moderator bearbeitet: 13. März 2010
  3. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    also bei mir funktionieren die o2 einstellungen nicht
     
  4. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    was genau funktioniert denn nicht? hast du vorher fAPN installiert, um dich manuell mit dem server verbinden zu können? also du musst bevor du die MMS abschickst manuell die verbindung zu deinem o2 profil, dass du erstellt hast verbinden.

    hast du auch vor deine telefonnummer die 00 vorschrieben? also quasi 00491761234567
     
    #4 spion83, 27. Apr. 2010
    Zuletzt bearbeitet: 27. Apr. 2010
  5. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    fapn ist eingerichtet !!!!!

    Internetverbinding fehlgeschlagen . Erneut versuchen ?

    Muß dabeisagen das ich die neuste version fmms druff habe

    Vielleciht kannst du mir ja mal den richtigen eingabevorgang schicken inkl. der o2 mobilcom settings

    danke
     
    #5 Spiderman-, 27. Apr. 2010
    Zuletzt bearbeitet: 27. Apr. 2010
  6. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    also ich habe fMMS 0.9.10. wahrscheinlich hast du nur die einstellungen in fMMS vorgenommen. also nochmal schritt für schritt
    1. lade fAPN. Erstelle eine Verbinung zb. o2 MMS.
    2. gehe im nokia n900 auf "EINSTELLUNGEN", "INTERNETVERBINDUNGEN" klicke auf VERBINDUNGEN. dort sollte jetzt dein mit fAPN erstelltes profil (o2 MMS) zu sehen sein
    3. klicke es an und gehe auf "BEARBEITEN"
    4. bei VERBINDUNGSNAME sollte schon dein eingestellter name stehen. bei VERBINDUNGSTYP sollte PAKETDATEN stehen. klicke auf WEITER
    5. Bei NAME DES ZUGANGSPUNKTES schreibst du "internet" rein. den rest lässt du leer. klicke WEITER
    6. jetzt steht dort ERWEITERT. da klickst du rauf.
    7. mache ein kreuz bei PROXY VERWENDEN. dann trage bei HTTP-proxy ein: 195.182.114.52 bei protnummer trägst du die 8080 ein. den rest lässt du leer, dann auf SPEICHERN und auf FERTIG

    nun solltest du wenn du oben auf die uhr im hauptmenü klickst und dann auf internetverbindung dich mit deinem profil verbinden können.

    in fMMS sollten die einstellungen wie auf dem bild aussehen

    [​IMG]
    [​IMG]
     
    #6 spion83, 27. Apr. 2010
    Zuletzt bearbeitet: 27. Apr. 2010
  7. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    danke für die schnelle antwort , aber genauso habe ich es gemacht
    aber es funzt trotzdem nicht .
     
  8. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    also ich habe mal gegoogelt und vielleicht liegt es daran, dass du o2 mobilcom hast. ich habe ein paar einstellungen gefunden, weiß aber nicht ob sie funkten. sie sehen gefolgt aus


    (APN: internet.debitel.de
    Benutzername: debitel
    Kennwort: internet
    das hier sind vermutlich die debitel interneteinstellungen)


    MMS einstellungen

    APN: wap.debitel.de
    Benutzername: debitel---> das bei den internetverbindungen
    Kennwort: mms---->ebendalls
    MMSC: http://10.81.0.7:8002---->das hier solltest du bei fMMS eingeben
    MMS-Proxy: 193.168.128.127:8080---->das hier solltest du bei internetverbinungen bei erweitert eintragen. den port natürlich nicht hinten ran sondern wahrscheinlich darunter.

    hier ist nen tread dazu

    http://iszene.com/thread-48712.html
     
    #8 spion83, 27. Apr. 2010
    Zuletzt bearbeitet: 28. Apr. 2010
  9. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    nö !!!

    funzt auch nicht , aber danke für deine mühe
     
  10. Zingel1986

    Zingel1986 Aktives Mitglied

    Registriert seit:
    15. Apr. 2008
    Beiträge:
    1.994
    Zustimmungen:
    1
    Die neueste Version (ab PR 1.2) soll wohl eine automatische Erkennung der MMS Einstellungen haben. Also wenn du dich etwas geduldest, wirst du ab Mai ohne großen Aufwand MMS empfangen können
     
  11. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    Laut dieser Liste gibt es im PR1.2 kein MMS


    The Nokia Phone Blog
     
  12. Zingel1986

    Zingel1986 Aktives Mitglied

    Registriert seit:
    15. Apr. 2008
    Beiträge:
    1.994
    Zustimmungen:
    1
    Richtig... aber das Programm fMMS 0.9.5 ist für die PR 1.2 optimiert und auf der PR 1.1.1 noch nicht nutzbar.
    Eben diese version der Programmes soll wohl die MMS Einstellungen automatisch erkennen
     
  13. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    na dann bin ich mal gespannt !!!!! ich glaube so lange kann ich noch warten , oder auch nicht :D.

    Hab keine lust meine mms jedesmal auf der inetseite von meinem anbieter anzuschauen.
     
  14. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    kannst du die daten nicht einfach mal bei deinem provider erfragen?

    bzw. kannst du mal unter internetverbindungen deine providerangaben, für das internetprofil einsehen und uns berichten, vielleicht kommen wir darüber ja ran, welche daten du brauchst.
     
  15. Spiderman-

    Spiderman- Neues Mitglied

    Registriert seit:
    13. Apr. 2010
    Beiträge:
    8
    Zustimmungen:
    0
    also !!

    habe jetzt Pr1.2 und fmms 1.0.4 druff . funzt immer noch nicht und die automatische erkennung ( wie schon geschrieben ) funzt weder mit der PR1.2 noch mit der aktuellsten FNNS version. Und Debitel verweist mich immer auf den handykonfigurator auf der webside wo mit dem n900 nur interneteinstellungen möglich sind
     
  16. Jennyq66

    Jennyq66 Neues Mitglied

    Registriert seit:
    21. Juli 2010
    Beiträge:
    2
    Zustimmungen:
    0
    so leute ich verstehe hier nur bahnhof habe auch das N900 und habe alles eingegeben was ich musste um mms zu verschicken.doch leider tut es dies nicht.er zeigt mir auch nicht mal die seite an wo ich meine eigene Handynummer eingeben soll.kann mir einer erklären woran das liegen könnte.

    Danke schon mal.lg Ich
     
  17. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    beschreibe mal bitte etwas genauer, was du alles installiert hast und bei welchem schritt es hängt. hast du fMMS installiert? welche version hast du installiert? welche PR verison hast du 1.1.1 oder 1.2?
     
  18. Jennyq66

    Jennyq66 Neues Mitglied

    Registriert seit:
    21. Juli 2010
    Beiträge:
    2
    Zustimmungen:
    0
    Die version kann ich dir nicht sagen hatte beides fmms und fapn.wenn man am ende fmms öffnet sollte eine seite sich öffnen wo man seine eigene Ha.nr. eingibt das macht er aber auch nicht es klappt nicht einmal manuel also keine ahnung.hab alles wieder gelöscht!!

    Fmms version ist 1.1.9

    Was meinst du mit PR????
     
    #18 Jennyq66, 26. Juli 2010
    Zuletzt bearbeitet: 26. Juli 2010
  19. spion83

    spion83 Neues Mitglied

    Registriert seit:
    26. Mai 2009
    Beiträge:
    95
    Zustimmungen:
    0
    PR ist die betriebssystemversion. also 1.1 oder 1.2. ich kann dir leider erst wieder helfen, wenn ich mein handy wieder habe, da ich mit der 1.1.9 version von fmms keine erfahrung habe, da mein telefon seit 2 monaten bei nokia unterwegs ist um angeblich repariert zu werden. bisher allerdings vergebens. bei nokia macht man lieber software-updates in rumänien, als mal nach hardware fehlern zu suchen. sobald ich es wieder habe, werde ich es mal ausprobieren.
     
Die Seite wird geladen...