Linux-Distributionen Der große Linux Thread

Dieses Thema im Forum "Software" wurde erstellt von evo_racer, 14. Apr. 2009.

  1. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Ja, gibt so 'ne Art syslog bei Maemo. Heißt als Paket aber sysklogd, installiert sysklogd und klogd (und libc6).
    Das mit der log-priority muss aber nach jedem Boot neu gesetzt werden (oder in den kernel settings/options ?häh? gesetzt werden). Mit ein bißchen Fingerspitzengefühl einfach ins pre-start script an den Anfang gesetzt und voila.
    Jetzt habe ich den output, alle events und state changes und ein "goal changed from start to stop". Daraus gefolgert, dass dies ein normaler Vorgang ist und mir nochmal die trigger angeschaut
    Code:
    start on started hildon-desktop
    stop on stopping hildon-desktop
    
    Damit wird mein script nach dem desktop gestartet, was ich so haben will. Und anhalten sollte er mit Beendigung des Desktops, also meines Wunsches nach mit dem shutdown.
    Aber man sollte sich die gewählten Trigger -und vor allem deren Herkunft- genau anschauen/auswählen.
    So sieht der job hildon-desktop aus:
    Code:
    description "Fake job for hildon-desktop"
    author "Pekka Lundstrom <pekka.lundstrom@nokia.com"
    console none
    
    start on XSESSIONS_STARTING
    stop on stopped xsession
    
    pre-start script
        [ -e /tmp/ACT_DEAD ] && exit 1
    
        while [ ! -e /tmp/hildon-desktop/desktop-started.stamp ]
        do
            sleep 2
        done
        # This is to make sure it's really functional by the time user
        # gets to use it.
        sleep 5
    end script
    
    Ohne main script/exec wird der Status direkt auf stopped durchgesetzt und damit mein job angetriggert.

    Einfach den Trigger
    Code:
    stop on stopping hildon-desktop
    
    in
    Code:
    stop on starting shutdown
    
    geändert und alles ist gut!

    Hätte man mir auch früher sagen können ;)
    Danke proti. :)
     
  2. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Naja, eigentlich hab ich ja nix gemacht :fresse Aber schön das es jetzt endlich funktioniert :)
     
  3. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Ja ne klar haste nix gemacht. :)
    Aber ohne den Tipp mit dem syslog wär ich selber wohl nie drauf gekommen, dass der hildon-desktop beim Start/Boot direkt von stoppped-started-stopped gesetzt wird. Manchmal/oft hilft eben einfach mit jemand reden/drüber gucken lassen.
     
  4. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Okay, dann freut es mich, dass ich dir zumindest mit dem Tip helfen konnte :) Allerdings weiß ich aber immer noch nicht so recht, was du damit eigentlich bezwecken möchtest :)
     
  5. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Schreib ich dir im N900 Bereich :)
    Für hier sollte als Grund reichen, dass ich einfach nur ein script ablaufen lassen möchte, welches nach jedem Boot automatisch gestartet und zyklisch eine bestimmte Aufgabe abarbeitet (while true; do something; sleep 600; done;)
    Dass ich solche Probleme damit hatte, war ja nu nich zu erwarten ...
     
  6. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Hallo,

    Habe noch mal ein Linux Problem: Ich finde kein Emerald unter Xubuntu 11.10, weder 32 noch 64-bit. Haben die das aus den Paketquellen genommen ? Oder hat es einen neuen Namen bekommen ?
     
  7. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Emerald gibts unter Ubuntu 11.10 nicht mehr. Benötigt man aber eigentlich auch nicht.

    Aber du kannst es trotzdem installieren, wenn du mit PPAs arbeitest und zwar so:

    Bevor du aber sudo apt-get update machst, musst du unbedingt in den Paketquellen von natty auf oneiric umstellen ;) Sonst kannst du es nämlich nicht installieren. Oder aber, du installierst es dir von Hand von der Seite.
     
  8. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    So, habe eine neue(s) Frage bzw. Problem:

    In Xubuntu macht Thunar Probleme: Ich habe zwei Festplatten, aber es wird nur die angezeigt, wo das System drauf installiert ist. Die zweite Platte ist NTFS und Windows drauf.
     
  9. chinwildchicken

    chinwildchicken VIP Mitglied

    Registriert seit:
    29. Jan. 2008
    Beiträge:
    566
    Zustimmungen:
    11
    Wenn du Xubuntu über Wubi installiert hast, also unter Windows, dann müsste deine Platte unter dem Verzeichniss /host zu finden sein. Hatte damals auch Suchprobleme bei meiner Wubi Installation :D
     
  10. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Also, ich habe kein Wubi verwendet, sondern mit einer LiveCD installiert, auf einer extra Festplatte. Mein Vorhaben ist einfach, das ich auf die Festplatte wo Windows installiert ist, unter Xubuntu drauf komme.
     
  11. Russe89

    Russe89 VIP Mitglied

    Registriert seit:
    10. Apr. 2009
    Beiträge:
    1.006
    Zustimmungen:
    6
    Du meinst, das die Festplatte eingehängt sein soll oder?
    Dafür musst du die datei /etc/fstab bearbeiten...
    Und das Verzeichnis erstellen, wo die dranhängen sollen..

    Weißt du wie die bezeichnung dieser Festplatte ist?
    Vermute mal die zweite platte wird bei dir /dev/sdb1 heißen...
    Schaue dir am besten mal folgendes an: Festplatten beim Hochfahren mounten - Anfängerprobleme-Archiv - Ubuntu-Forum & Kubuntu-Forum | www.Ubuntu-Forum.de

    Dort steht es denke ich genau genug beschrieben in Post#11, du musst den letzten Punkt einfügen der in seinem Quellcode steht, aber erstmal musst du sicher sein das die zweite Festplatte auch wirklich sdb2 ist ;) Wenn die platten unterschiedliche größen haben, reicht es wenn du
    Code:
    df -h
    im terminal eingibst. Dort werden dir die Größen einiger Verzeichnisse angegeben.

    Russe
     
  12. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Wieso ist es gerade unter Xubuntu so kompliziert? Ich meine unter Ubuntu oder Kubuntu muss man das ganze nicht machen.
     
  13. Russe89

    Russe89 VIP Mitglied

    Registriert seit:
    10. Apr. 2009
    Beiträge:
    1.006
    Zustimmungen:
    6
    Das war jetzt eine allgemeine Anleitung die auch für Ubuntu läuft...
    Zumindest habe ich bei mir die Festplatte genauso eingebunden.

    Die Anleitung kommt ja auch aus einem Ubuntu-Forum.

    Russe
     
  14. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Standardmässig werden unter Xubuntu auch nur die Laufwerke angezeigt, die eingehangen sind. Unter (K)ubuntu muss man das nicht. Das liegt eigentlich auch nur daran, weil Xubuntu ja eher auf minimalismus zählt. Und so schwer ist das nicht. Zumal auch unter den anderen Ubuntuversionen das manuelle Einhängen bevorzugen sollte, weil es nämlich sonst ein Rechtproblem gibt :D
     
  15. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Also, ich hätte da mal ein Paar neue Fragen ( Bin auf Ubuntu 10.04 64-bit zurück)

    1. Ich habe einen Realtek Wlanstick mit RTL8192CU Chipsatz. Auf der beigelegten CD liegen Treiber bis Win7 64-Bit dabei. Ich versuche diese mit Ndiswrapper einzubinden. Es wird angezeigt das die Hardware erkannt wurde, aber es wird kein Wlan gesucht bzw verbunden über den Network-Manager.
    Dann habe ich auch noch einen Linux-Treiber auf der CD gefunden, den habe ich versucht zu installieren, doch das Terminal bricht mit ,, Compile make driver error 2,, ab. Was könnte ich da machen?

    2. Wie bekomme ich, nachdem ich den proprietären Ati Treiber installiert habe, den originalen und nicht den Textbasierten, Plymouth von Ubuntu wieder ? Seit dieser Treiber installiert ist, sieht man ein einfaches Ubuntu in normaler Schrift mit Ladepunkten darunter und dann ne menge Text bis zur Anmeldekonsole (die aber wieder grafisch ist)

    Hoffe ihr könnt mir helfen
     
  16. chinwildchicken

    chinwildchicken VIP Mitglied

    Registriert seit:
    29. Jan. 2008
    Beiträge:
    566
    Zustimmungen:
    11
    Das 2. Problem hängt damit zusammen, das du den propritären Treiber installiert hast, das ist normal. Bei Ubuntuusers gibt es einen Tipp dafür,hat bei mir geholfen :)

    Plymouth

    Für 1.

    Geht der Stick aber bei neueren Versionen von Ubuntu ? Ansonsten je nachdem wie es geht würde ich versuchen die Backporttreiber zu installieren. Mir jedenfalls hat es die Verbindung stabiler gemacht, oft helfen sie beim erkennen, schau mal hier rein

    Linux-backports-modules

    Ansonsten versuch das hier manuell, sollte helfen :)

    D-Link DWA-121: Treiber einrichten
     
  17. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Dankeschön! hat super funktioniert. Jetzt stehe ich vor einer weiteren Hürde, auf die ich noch keine Lösung gefunden habe: Ich habe ein Transformation Pack in Einzelteilen gedownloadet. Es wird verlangt mit gksudo ins Dateisystem zu gehen, und dort alle Dateien, von Hand in die Ordner zu verschieben. Soweit funktioniert das, aber die GTK-Themes, Icons etc. werden in den Menüs nicht erkannt oder angezeigt. Wo liegt da das Problem ? Hier noch die Anleitung zu dem Pack: Windows 7 gratis klonen - Ubuntu-Modding - Windows 7 gratis klonen - Ubuntu-Modding - Nickles
     
    #197 pcgamer, 28. Dez. 2011
    Zuletzt bearbeitet: 28. Dez. 2011
  18. chinwildchicken

    chinwildchicken VIP Mitglied

    Registriert seit:
    29. Jan. 2008
    Beiträge:
    566
    Zustimmungen:
    11
    Hm, also die Icons und GTK Designs installierst du, indem du mit Rechtsklick auf Hintergrund ändern auf Designs gehst. Jetzt ziehst du diese Archive mit der Endung .tar.gz worin eben das GTK Design oder die Icons liegen, einfach dort hinein ins Fenster, dann kannste die auswählen :)

    Das schwierigste wie ich finde daran ist ja das die Fenster die Windowsschaltflächen bekommen sollen und eben auch so einen Transpararenten Blureffekt bekommen.

    In diesem Fall musst du halt emerald installieren, um aber umschalten zu können noch das Fusion Icon ( gibts im Softwarecenter alles). Anschließend noch die .emerald Datei reinmachen und mit dem Fusion Icon von GTK zu Emerald wechseln. Damit das so bleibt im Autostart emerald --replace eingeben...

    Klingt etwas kompliziert? Das stimmt, unter Kubuntu ist das ganze irgendwie einfacher, da kann man die Designs aus kde-look.org direkt durchsuchen und direkt übernehmen. Je nach dem würde ich an deiner Stelle KDE nachinstallieren :)
     
  19. pcgamer

    pcgamer Mitglied

    Registriert seit:
    17. Mai 2010
    Beiträge:
    227
    Zustimmungen:
    2
    Diese Methode kenn ich schon, nur das Problem ist eben: Die Dateien sind einzeln, also nicht in tar.gz Verzeichnisse. Ich könnte sie natürlich in tar.gz Verzeichnisse verschieben.. und anschließend installieren. Es ist nur eben, die andere Methode müsste auch funktionieren, tut sie aber nicht.
     
  20. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Versteh mich bitte nicht falsch, aber das ist echt eine ganz ganz blöde Idee was du da machst. Es mag vielleicht auf den ersten Blick super toll aussehen und du kannst damit auch angeben, aber was ist, wenn du das wieder rückgängig machen willst, oder du anderweitig ein Theme verwenden willst. Auch ist nachteilig, dass das "Theme" Systemweit installiert wird, dass ist mehr als problematisch. Themes, die man per Hand installiert, sollten/müssen auf Userebene arbeiten. Das heisst, sie müssen in den Ordner .themes in deinem Homeordner "installiert" werden.

    Warum? Wie gesagt, wenn du es mal wieder loshaben willst, geht das gerenne und gesuche nach den Dateien wieder los. Tolles Schauspiel und die meisten geben dann wieder auf und wechseln -.- Echt klasse...

    Trägt jetzt zwar nicht zur Lösung bei, aber wollts dennoch mal gesagt haben :)
     
Die Seite wird geladen...