Xperia X10 Xperia X10 - Wie framework-res.apk übertragen?

Dieses Thema im Forum "Sony Ericsson" wurde erstellt von Warrock, 15. Feb. 2011.

  1. Warrock

    Warrock Guest

    Hallo ;)

    Habe nach der Anleitung von dodotech (http://www.faq4mobiles.de/forum/android-faq-und-anleitungen/93705-custom-framework-selbst-erstellen-auf-einem-androiden.html) meine Framework.apk bearbeitet. So..

    Wollte dann diese Befehle eingeben, um die .apk wieder zu übertragen.

    An dem Punkt
    schreibt das Programm mir, das ich only-read Rechte habe, wie komm ich da weiter ?

    Den Anhang x10i framwork-windows.bmp betrachten
     
  2. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
  3. Warrock

    Warrock Guest

    Ja, Root Rechte habe ich.

    Danke ;) Werd es ausprobieren.

    --- Edit ---

    habe jetzt meine bearbeitete framework ausgewählt.

    Ganz unten zeigt er mir an :

    Pull Backup ; Browse ; Send ; Force send

    Welches Send soll ich nehmen ? Weil bei Force send " use only if phone is stuck on boot (Needs Shell Root) " steht.
     
  4. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
    Nur "Send" reicht aus.
     
  5. Warrock

    Warrock Guest

    Habe ich gemacht..

    Handy bleibt an, startet von selber nicht neu.
    Manuell rebootet > Und was dann ? Kein einziges Bild wurde ersetzt...
     
  6. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
    Handy mit eingeschaltetem USB-Debugging verbunden?

    Wurde die Datei überhaupt übertragen, also ist die Leiste von links nach rechts durchgelaufen?

    Bist du dir auch sicher, dass du die framework-res.apk richtig bearbeitet hast?
     
  7. Warrock

    Warrock Guest

    Also.
    Ja USB debbuging aktiviert.
    Habe nochmal auf "Send" gerückt, und dabei auf das Handy geschaut, wie es reagiert.
    Dann kam eine Anfrage von SU . Habe ich natürlich auf Erlauben gedrückt.
    Dann hat das Handy von allein rebootet.
    Trotzdem sind die Bilder nicht erstzt worden :/
     
  8. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
    Dann hast du was beim Editieren der framework-res.apk falsch gemacht...

    Probiere es mit bereits vorgefertigten Themes > siehe X10 Forum...
     
  9. Warrock

    Warrock Guest

    So, jetzt bin ich, so wie immer wenn ich was mit der Framework mache, in der Bootschleife gelandet ;) .

    Werde wieder neu flashen :D . lol -.-

    --- Edit ---

    Öhm.. beim rumhantieren vom Akku entfernen, bin ich wohl auf die Zurücktaste gekommen.

    Jetzt bin ich im xrecoverx Menü :D

    Lässt sich da drüber noch was machen ? Bevor ich neu flashen muss ? :D

    So hammer -.-

    --- Edit ---

    Hatte vor ca . 2 Stunden mit xRecovery ein backup angelegt..

    Hab dann mal das Backup aus dem Reovery Menü aufgespielt.. und siehe da es funktioniert wieder .

    Dann muss ich jetzt ja garnicht mehr neu flashen :D
     
Die Seite wird geladen...