E7-00 Suche Python für E7 mit Belle

Dieses Thema im Forum "Nokia Forum" wurde erstellt von shockshwerenot, 25. Feb. 2012.

  1. shockshwerenot

    shockshwerenot Neues Mitglied

    Registriert seit:
    24. Mai 2011
    Beiträge:
    24
    Zustimmungen:
    0
    liebe leute, ich blicks mal wieder nicht. gibt es denn eine python runtime, die sich mit symbian belle verträgt und obendrein installieren lässt?

    habe es beispielsweise mit dem "Ultimate Python Pack v6" von dieser website versucht:

    http://www.faq4mobiles.de/downloads.php?do=file&id=8971

    nach der signierung meinerseits heißt es aber bei der installation. "Programm nicht mit dem Telefon kompatibel. Trotzdem fortfahren?" fahre jedoch nicht fort, da ich das system nicht gefährden will.

    weiß eine(r) rat? vllt. einen link zu einer verlässlichen sis-datei?

    danke und ein schönes we
     
  2. shockshwerenot

    shockshwerenot Neues Mitglied

    Registriert seit:
    24. Mai 2011
    Beiträge:
    24
    Zustimmungen:
    0
    sorry! hat sich wohl erledigt ... habe dann doch nochmal die etwas ältere version von hier

    http://www.faq4mobiles.de/downloads.php?do=file&id=8067

    installiert. klappte tatsächlich, obwohl unter dem link von "Betriebssystem: Symbian S60v3" die rede ist, und ich symbian belle eher zu S60v5 geählt hätte. kenne mich da aber nicht so aus ..

    danke trotzdem, also auch für das programm!
     
  3. Deadman

    Deadman Super-Moderator

    Registriert seit:
    17. Jan. 2008
    Beiträge:
    16.555
    Zustimmungen:
    393
    Belle ist Symbian^3.

    Hat nichts mit S60v3 oder S60v5 zu tun.

    Python brauchst du bei Symbian^3 auch nicht mehr.

    LG
     
  4. pommesmatte

    pommesmatte Super-Moderator
    Mitarbeiter

    Registriert seit:
    27. Nov. 2008
    Beiträge:
    6.034
    Zustimmungen:
    29
    Wie kommst du denn auf den Trichter?
    Um Python Programme zu benutzen brauchst du natürlich Python!
     
  5. shockshwerenot

    shockshwerenot Neues Mitglied

    Registriert seit:
    24. Mai 2011
    Beiträge:
    24
    Zustimmungen:
    0
    na ja, es ist nur so, dass es geholfen hat. ich konnte danach die installation eines programms namens magicM3U vornehmen ... um schlussendlich in der musikbibliothek ordnung zu schaffen, was mir allerdings noch bevorsteht.

    wieso sollte ich python unter belle nicht mehr benötigen?
     
  6. Deadman

    Deadman Super-Moderator

    Registriert seit:
    17. Jan. 2008
    Beiträge:
    16.555
    Zustimmungen:
    393
    Welche Python Programme gibt es unter Symbian^3? Ich kenn keins.

    Vorallem läuft Python auf Symbian^3 total fehlerhaft. Ich hab es auf den N8 damals getestet.

    LG
     
  7. huellif

    huellif VIP Mitglied

    Registriert seit:
    11. Juli 2011
    Beiträge:
    494
    Zustimmungen:
    0
    Wurde python nicht in qt integriert?
     
  8. Deadman

    Deadman Super-Moderator

    Registriert seit:
    17. Jan. 2008
    Beiträge:
    16.555
    Zustimmungen:
    393
    Eigentlich schon, aber keine ExtraPacks meines Wissens. :D

    LG
     
  9. pommesmatte

    pommesmatte Super-Moderator
    Mitarbeiter

    Registriert seit:
    27. Nov. 2008
    Beiträge:
    6.034
    Zustimmungen:
    29
    Der Witz von Python ist doch gerade, dass Programme praktisch überall laufen können, wo das Framework läuft.
    Alle S60 Python Programme laufen auch unter S^3. Einzig die Touchbedienung macht manchmal Probleme.

    Python läuft bei mir auf jeden Fall fehlerfrei und ich hab auch mehrere Python Programme laufen.
    Prominentestes Beispiel ist sicher FreiMinMon.

    Und mit Qt hat Python erstmal nix zu tun.
    Es gibt allerdings ne Anbindung PyQt mit der Pythoncode dann unter Qt ausgeführt werden kann, genauso wie es auch APIs für Java, PHP und und und gibt.
    Ist aber meines Wissens nicht auf S^3 installiert.

    Pythonprogramme laufen nämlich trotzdem auf S^3 nicht ohne Python.
     
  10. shockshwerenot

    shockshwerenot Neues Mitglied

    Registriert seit:
    24. Mai 2011
    Beiträge:
    24
    Zustimmungen:
    0
    um die sache nun vollends abzurunden: @pommesmatte

    welches pythonpaket ist denn deines erachtens das sinnvollste für/lauffreudigste unter belle? ist es vllt. das oben genannte "Python S60 v2.0.0.sisx", das auf dieser webseite als download angeboten wird? falls nicht, welches eher?
     
  11. pommesmatte

    pommesmatte Super-Moderator
    Mitarbeiter

    Registriert seit:
    27. Nov. 2008
    Beiträge:
    6.034
    Zustimmungen:
    29
    Erstmal musst du wissen, ob dein Programm Python 1.4.x oder 2.x braucht.

    Es schadet aber auch nicht beides zu installieren, aber 2.x Programme laufen tendenziell besser. Probier sonst erst 2.x aus.

    2.x gibts hier:
    http://www.faq4mobiles.de/downloads.php?do=file&id=8067 (das hast du wohl schon installiert)
    Die ScriptShell dazu:
    http://www.faq4mobiles.de/downloads.php?do=file&id=8374


    1.4.x gibts hier (Version für v3 und v5 benutzen)
    http://www.faq4mobiles.de/downloads.php?do=file&id=4398
    ScriptShell:
    http://www.faq4mobiles.de/downloads.php?do=file&id=5710

    Eventuelle Kompatibilitätshinweise ignorieren.

    Mehr Infos dazu auch hier:
    http://www.faq4mobiles.de/nokia-faq...gen-und-antworten-zu-nokia-handys.html#frage3
     
  12. shockshwerenot

    shockshwerenot Neues Mitglied

    Registriert seit:
    24. Mai 2011
    Beiträge:
    24
    Zustimmungen:
    0
    nun wird einiges klarer. hätte ja auch mal selbst insbesondere die faq's durchstöbern können.

    da das programm sich mit 2.0 zufrieden zu geben scheint, ist erst mal alles im lot.

    herzlichen dank auch
     
Die Seite wird geladen...