N97 mini Sprache in CFW einfügen

Dieses Thema im Forum "Nokia Forum" wurde erstellt von SymbianFan, 18. Juli 2011.

  1. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Hi,

    Ich habe mit dem RLT GUI v. 1.9.9 aus einer N97-FW eine Sprache extrahiert und dann in die CFW eines N97 (gehört meinem Bruder) eingefügt. Aber jedesmal kommt nach dem Flash fast ununterbrochen eine Fehlermeldung "Systemfehler". Und den Einstellungseintrag "Sprache" kann nicht geöffnet werden.

    Was habe ich falsch gemacht? Kennt jemand den Fehler?

    Vielen Dank im Voraus.

    Grüße
     
  2. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Ist das ne C6-CFW? Wie heißt die CFW deines Bruders?
     
  3. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Eine gewöhnliche N97-FW, die ich bearbeitet habe. :D

    Ich habe Lösung gefunden!

    Ich habe nämlich immer wieder die Datei "ecom-2-0.spi" in private\10009d8f mit der extrahierten Sprache (Japanisch) ersetzt. Diesmal habe ich sie nicht ersetzt. Ergebnis: Keine Fehlermeldung und Einstellungspunkt "Sprache" lässt sich öffnen. Auch die Sprache Japanisch lässt sich auswählen.
    Jedoch besteht das Problem, dass die japanischen Buchstaben nicht zur Verfügung stehen, wenn man z.B. eine Mitteilung schreiben will.
     
    #3 SymbianFan, 18. Juli 2011
    Zuletzt bearbeitet: 18. Juli 2011
  4. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Welche Sprache wird benötigt?
     
  5. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Steht oben: Japanisch
     
  6. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Ah ok:D Du nimmst aber die Spachdatei aus der gleichen Firmwareversion oder?
    Oder warum nimmst du nicht direkt ne Japanische Firmware und bearbeitest diese?
     
  7. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ja, natürlich.

    Du meinst, dass ich direkt die japanische FW bearbeite und in ihr die deutsche Sprache einfüge? Ist es so besser? Wird es eigentlich immer so gemacht?

    Grüße
     
    #7 SymbianFan, 18. Juli 2011
    Zuletzt bearbeitet: 18. Juli 2011
  8. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Es ist egal wie man es macht aber vielleicht klappt das so;)
     
  9. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Besten Dank für den Tipp!! Es hat so geklappt!

    Aber es gibt ein Problem: Wenn ich die deutsche Sprache auswähle, werden alle Ordner mt "qtn_apps_xxxx" beschriftet. Gibt es dafür eine Lösung?

    Aber sonst passt alles! ;)

    Grüße
     
  10. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Ist ein Menümod in der CFW?
     
  11. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Nein.

    Aber danach ist mir das mit dem Menümod eingefallen. Also habe ich die "matrixmenudata.dtd" von der deutschen FW in meine CFW kopiert. Problem gelöst!

    Vielen Dank für deine Hilfe!!

    Grüße
     
  12. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Habe gerade ein kleines Problem festgestellt: Wenn ich z.B. mit der Tastatur die Umlaute bzw. das "ß" eingeben möchte, werden stattdessen andere Zeichen eingegeben.

    Ich habe die japanische "ecom-2-0.spi" belassen und nicht mit der deutschen "ecom-2-0.spi" ersetzt. Damit der T9-Support für die japanische Sprache erhalten bleibt. Jedoch hat dadurch das N97 keinen deutschen T9-Support bzw. unterstützt nicht die Eingabe aller deutschen Buchstaben. Wie kann dieses Dilemma gelöst werden?

    Grüße
     
  13. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Kann ich die "ecom-2-0.spi" von beiden Sprachen einfügen?
     
  14. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Wie soll das klappen? Dateien mit gleichen Namen werden ersetzt;)
     
  15. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Indem man z.B. die andere leicht umbenennt. Aber wahrscheinlich ist das Blödsinn, was ich da von mir gebe. Aber wie zum Teufel kann ich dann das Problem mit der Tastatur lösen?

    @LZ

    Kannst du mir vielleicht helfen?
     
  16. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Erklär mir bitte nochmal was du willst. Wofür willst du Japanisch wenn du auf Deutsch schreiben willst?
     
  17. SymbianFan

    SymbianFan VIP Mitglied

    Registriert seit:
    16. Mai 2011
    Beiträge:
    1.255
    Zustimmungen:
    0
    Ich will Japanisch + japanische Eingabemöglichkeit als auch Deutsch + deutsche Eingabemöglichkeit (deutsche Qwertz-Tastatur-Layout).
     
  18. kevinus

    kevinus Top Supporter

    Registriert seit:
    16. Mai 2010
    Beiträge:
    2.157
    Zustimmungen:
    37
    Achso :) Ich werd nochmal gucken was man machen kann.
     
Die Seite wird geladen...