Problem mit Linuxkernel N900 Flash?

Dieses Thema im Forum "Maemo / MeeGo Forum" wurde erstellt von Caffeineshock, 28. Nov. 2011.

  1. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    wenigstens findet man hier zuflucht als nokia n900 user
    folgendes problem:
    seit kurzem habe ich nicht mehr die möglichkeit auf die möglichkeiten des powerkernels zuzugreifen, was auch klar ist, da ich es nicht booten kann "failed to flashxxxxxxxxxx. hit any key to panic" müsste einigen von euch bekannt vorkommen.
    nun. ich kann den kernel nicht deinstallieren, nicht neuinstallieren und es kommt nach dem entsperren der tastatur "Package "kernel-power-settings" not found!" obwohl es drauf ist. ansonsten läuft das handy 1a
    nun meine frage:
    wenn ich es geschafft haben sollte, mein problem deutlich niederzuschreiben wüsste ich gerne eine möglichkeit mein handy wieder ohne einen flash zum laufen zu kriegen.
    pr 131
    neuester powerkernel
    ohne cssu.
    mit bootloader.
     
  2. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.693
    Zustimmungen:
    40
    Naja, flashen musst du so oder so, aber du kannst doch mit dem Flashertool auch nur den Kernel flashen ;)
     
  3. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Welche Version des "neuesten" kernels?
    Die aus palis repository? Wenn ja, welche? Da gab e so viele (bugs)?

    Ansonsten wie installiert?
    Welche Reihenfolge?
    Und sicher auch das neue Paket kernel-power-settings mit installiert?

    Und was heisst jetzt :
    da ich es nicht booten kann
    ansonsten läuft es 1a
    innerhalb eines Satzes???
     
  4. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    welche version das ist kann ich das ja net nachsehen. auf alle fälle aus den extra-repos
    reihenfolge? der machts autpomatisch o_O und ich bin mir sicher, dass es richtig ist. das handy funzte jetzt monate lang ohne probleme, erst seit nem absturz
    ich kanns ja ohne den power kernel booten, da läuft es 1a, auser der tastensperren bug, von wegen "linux power kernel not found".
    kernel ist nicht bootbar, nicht uninstallierbar o.ä.
     
  5. Russe89

    Russe89 VIP Mitglied

    Registriert seit:
    10. Apr. 2009
    Beiträge:
    1.006
    Zustimmungen:
    6
    dann wohl per flasher-3.5 nur den kernel neu installieren, weiß jetzt gerade nicht 100% wie das war, müsste sowas in der art sein:
    Code:
    sudo flasher-3.5 --flash-only=kernel -F fw1.3.bin -f -R
    Russe

    /Edit: na war fast richtig, hier aus dem wiki.maemo.org bereich:
    Code:
    sudo ./flasher-3.5 -F <firmware-image> --flash-only=kernel -f -R
    <firmware-image> wird eben ersetzt durch die RX51*** .bin datei, also eben die mit welcher du auch das handy neu machst (NICHT das vanilla emmc Image!)
     
  6. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Hei, endlich geht mal wieder was hier ;)
    @russe
    das wird ihm nicht helfen. da sein Gerät ja mit normalem kernel bootet, so wie ich ihn verstehe.

    MULTIBOOT wäre ein nettes Stichwort gewesen, so es denn genutzt wird von caffe?
    Ansonsten müsste er ja eh obiges verwendet haben.

    Du sagtest Absturz?
    Eventuell file system corrupt
    Code:
    sudo fsck -n /home
    
    Oder hattest du irgend was anderes installiert? Ooder PK upgrade gemacht?
     
  7. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    hilf alles nichts... muss komplett flashen
    das flashen des kernels hat null gebracht. fsck gab nach 1 sekunde ein okay raus.
    flash flash flash ;)
     
  8. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Hey caffeine,

    so wie ich dich kenne, bist du eh schon fertig mit dem flash, oder? ;)
    Ansonsten hättest du nochmal probieren können, dir die einzelnen DEBsl runter zu laden und nochmal manuell zu installieren....
     
Die Seite wird geladen...