Galaxy S Modding: farbige Akkuanzeige in Prozent für das i9000 Galaxy S

Dieses Thema im Forum "Weitere Samsung Smartphones" wurde erstellt von logofreax, 2. Okt. 2010.

  1. logofreax

    logofreax Gründer

    Registriert seit:
    21. Apr. 2006
    Beiträge:
    42.420
    Zustimmungen:
    1.039
    Viele so auch ich, finden die Akkuanzeige beim i9000 viel zu unpräzise und langweilig.

    Es gibt zwar diverse Apps im Android Market, die eine zusätzliche % Anzeige ermöglichen, aber eben nur als zusätzliches Icon oder irgendwelche Widgets.

    Aber es geht auch anders und das kinderleicht.

    Hier mal meine neue Anzeige:

    snap20101002_211330.png

    Hier mal eine Übersicht der möglichen Styles:

    Version A:
    Version A.png

    Version B:
    Version B.png

    Version C:
    Version C.png

    Version D:
    Version D.png

    Version E:
    Version E.png

    Version F:
    Version F.png

    Die Installation ist wirklich einfach.

    Voraussetzungen:

    - Root

    1.) Auf der folgenden Page sucht man sich je nach installierter Firmware den passenden Link zum runterladen für das gewünschte Design aus:

    Link: The Fightspit's Circle Battery mod repository thread - xda-developers

    2.) Nach dem runterladen entpackt man die Datei und hat dort eine Datei "framework-res.apk"

    3.) Jetzt die folgende Datei runterladen und entpacken: Den Anhang Change Framework.zip betrachten

    4.) die Datei "framework-res.apk" in den entpackten Ordner Change Framework kopieren

    5.) USB-Debugging im Handy aktivieren

    6.) Handy mit dem USB-Datenkabel verbinden

    7.) die Datei "Change Framework.bat" starten und die Super-User App Abfrage bestätigen.

    02-10-2010 21-36-56.jpg

    8.) ab jetzt läuft alles automatisch ab. Einfach abwarten. Nach dem automatischen Neustart ist die Akkuanzeige geändert.
     
  2. kekz29

    kekz29 Neues Mitglied

    Registriert seit:
    13. Aug. 2009
    Beiträge:
    45
    Zustimmungen:
    0
    Wo kann man eigentlich genau sehen ob die Installierte Firmware 100 gerootet ist ..

    hab nämlich grad das problem das ich die Batterieanzeige nicht changen kann... wobei SU app drauf ist ... die meldung auch kommt der Zugriff wurde gewährt aber passieren tut nix mehr in dem hässlichen grünen fensterchen ...

    nur son text

    cannot preserve ownership of bla xxx operation not permitted

    denke mal root fehlt oder ?^^

    nachtrag nicht nur verschieben auch was sagen @ logo ^^
     
    #2 kekz29, 3. Okt. 2010
    Zuletzt bearbeitet: 3. Okt. 2010
  3. kekz29

    kekz29 Neues Mitglied

    Registriert seit:
    13. Aug. 2009
    Beiträge:
    45
    Zustimmungen:
    0
    hier mal logo meine error meldung ... :(

    wie schon in PM geschrieben alles auch nach dem neuen install anweisungen gemacht selbe ergebniss .. :(

    ick wes nimma weiter :) das ding kommt gleich an die wand :)

    [​IMG]

    und da bleibts dann auch hängen wie gesagt mehrere stunden über nacht :(
     
  4. kekz29

    kekz29 Neues Mitglied

    Registriert seit:
    13. Aug. 2009
    Beiträge:
    45
    Zustimmungen:
    0
    Prozentanzeige für das Batteriesymbol

    Das Tool laden entpacken, am besten nach c:\hello
    Die framework-res.apk aus unten stehenden Link in den gerade erstellten Ordner entpacken.
    * Handy per USB an den Rechner anschließen, vorher am Gerät in den Debuggin Modus wechseln
    * Start>>>Ausführen>>>"cmd" eingeben
    * In den Ordner wechseln in dem sich die adb.exe und die framework-res.apk befindet.
    Für alle die nicht die geringsten Kenntnisse von DOS haben:
    2 x cd..
    cd hello
    * Am Handy ConnectBot starten(eventuell installieren)
    local connecten
    *Folgendes eingeben:
    su
    busybox mount -o remount,rw /system

    dann sollte nix erscheinen ne fehlerfreie leere Zeile

    *Am PC in der DOS-Box folgendes eingeben:
    adb push framework-res.apk /sdcard/framework-res.apk
    adb shell
    su
    rm /system/framework/framework-res.apk
    mv /sdcard/framework-res.apk /system/framework/framework-res.apk
    sync
    reboot

    so hats bei mir nun schluss endlich auch geklappt

    greetz
     
  5. intenso80

    intenso80 VIP Mitglied

    Registriert seit:
    6. Jan. 2010
    Beiträge:
    1.097
    Zustimmungen:
    1
    ich schnall das nicht ganz...
    habe die anleitung exakt befolgt. das einspielen ging auch ganz flüssig.
    neu gestartet hat er auch.... doch beim bootlogo bleibt das telefon hängen und vibriert ab und an mal...
    habe bereits die werkseinstellungen hergestellt, doch nix passiert....
     
  6. kekz29

    kekz29 Neues Mitglied

    Registriert seit:
    13. Aug. 2009
    Beiträge:
    45
    Zustimmungen:
    0
    Root + Lagfix installed ??? wann ist der fehler aufgetretten hatte das selbe mal. wolltest das battery icon switchen oder ist das beim flash auf firmware und co. passiert ?
     
  7. intenso80

    intenso80 VIP Mitglied

    Registriert seit:
    6. Jan. 2010
    Beiträge:
    1.097
    Zustimmungen:
    1
    das ist beim bzw. nach dem einspielen des battery icons passiert.
    root und lagfix waren bereits drauf ... ohne root währ die sache ja sowieso nicht gegangen...
    ich hab jetzt erstmal die angebl. offizielle 2.2 version aufgespielt.
    sprich:

    pda: XXJPM
    phone: XXJPK
    csc: unknown

    mal sehen obs für die neue firmware auch ein battery icon gibt, dann versuch ich es nochmal.
     
  8. logofreax

    logofreax Gründer

    Registriert seit:
    21. Apr. 2006
    Beiträge:
    42.420
    Zustimmungen:
    1.039
  9. intenso80

    intenso80 VIP Mitglied

    Registriert seit:
    6. Jan. 2010
    Beiträge:
    1.097
    Zustimmungen:
    1
    dumme frage, gibts für die offizielle 2.2 XXJPM auch ein app oder passende files zum modden?

    so bei XDA haben se jetzt die JPM auch berücksichtigt...

    als ich das modden zum ersten mal gemacht habe, (siehe oben) habe ich die oben beschriebene anleitung verwendet. doch die hat ja nicht zu 100% geklappt. zumindest nicht bei mir.
    ich habe dieses mal das modden via updatemethode aufgespielt.

    sprich, das zur firmware passende file runtergezogen, auf update bzw. update.zip umbenannt und in den internen telefonspeicher kopiert.
    danach in den recovery mode (volume up + home + power button) und dann auf upply sdcard: update.zip und mit der hometaste bestätigt. alles andere geht ja autom.
    nun funktioniert alles =)
     
    #9 intenso80, 16. Okt. 2010
    Zuletzt bearbeitet: 16. Okt. 2010
  10. Cornsnake30

    Cornsnake30 Neues Mitglied

    Registriert seit:
    30. Jan. 2010
    Beiträge:
    85
    Zustimmungen:
    0

    Genau das selbe Problem habe ich auch.
     
  11. kekz29

    kekz29 Neues Mitglied

    Registriert seit:
    13. Aug. 2009
    Beiträge:
    45
    Zustimmungen:
    0
    jo da gibt das superuserapp den zugriff nicht richtig aus nimm mal die vorgehensweise wie von mir beschrieben..

    Prozentanzeige für das Batteriesymbol

    Das Tool laden entpacken, am besten nach c:\hello
    Die framework-res.apk aus unten stehenden Link in den gerade erstellten Ordner entpacken.
    * Handy per USB an den Rechner anschließen, vorher am Gerät in den Debuggin Modus wechseln
    * Start>>>Ausführen>>>"cmd" eingeben
    * In den Ordner wechseln in dem sich die adb.exe und die framework-res.apk befindet.
    Für alle die nicht die geringsten Kenntnisse von DOS haben:
    2 x cd..
    cd hello
    * Am Handy ConnectBot starten(eventuell installieren)
    local connecten
    *Folgendes eingeben:
    su
    busybox mount -o remount,rw /system

    dann sollte nix erscheinen ne fehlerfreie leere Zeile

    *Am PC in der DOS-Box folgendes eingeben:
    adb push framework-res.apk /sdcard/framework-res.apk
    adb shell
    su
    rm /system/framework/framework-res.apk
    mv /sdcard/framework-res.apk /system/framework/framework-res.apk
    sync
    reboot

    sollte so dann gehen
     
  12. Cornsnake30

    Cornsnake30 Neues Mitglied

    Registriert seit:
    30. Jan. 2010
    Beiträge:
    85
    Zustimmungen:
    0
    Habe ich auch schon probiert, aber keine Ahnung was ich damit ConnectBot machen soll.
     
  13. intenso80

    intenso80 VIP Mitglied

    Registriert seit:
    6. Jan. 2010
    Beiträge:
    1.097
    Zustimmungen:
    1
    ich habe vorhin unter anderem auch versucht, die akkuanzeige bei der JPO zu ändern..
    JPO rar vom link gezogen, auf update.zip umbenannt und via recovery methode geupdatet. doch der update schlägt jedes mal fehl. :confused:
    bei älteren versionen der 2.2 firmware hat das update jedes mal geklappt.


    EDIT:

    wer mit der JPO probleme hat, der kann einfach eine version der JPM nehmen. funktioniert bei der JPO genau so... =)
     
    #13 intenso80, 14. Nov. 2010
    Zuletzt von einem Moderator bearbeitet: 14. Nov. 2010
  14. Querkopf

    Querkopf Neues Mitglied

    Registriert seit:
    17. Nov. 2010
    Beiträge:
    9
    Zustimmungen:
    0
    Hallo.

    Hab den gleichen Fehler.

    Darf ich fragen, wie Du die 2.2 draufgespielt hast? Mit Kies gehts nämlich nicht mehr, erkennt mein SGS nicht.

    Grüße
     
  15. Cornsnake30

    Cornsnake30 Neues Mitglied

    Registriert seit:
    30. Jan. 2010
    Beiträge:
    85
    Zustimmungen:
    0
    Ich habe diese Version Version drauf gemacht: I9000XXJPP - Downloads - FAQ4Mobiles
    Es geht mit Odin.

    Das soll die jetzt veröffentlichte Version von Samsung sein, also die die man über Kies bekommt.
     
  16. Querkopf

    Querkopf Neues Mitglied

    Registriert seit:
    17. Nov. 2010
    Beiträge:
    9
    Zustimmungen:
    0
    Download- und Recovery-Mode scheinen bei mir deaktiviert zu sein. Irgendeine Chance, das Ding wieder zum Laufen zu bekommen?

    Jetzt weiß ich wieder, warum ich das bei meinen letzten Handies einfach gelassen habe ...


    Edit:
    Übers SDK hab ich den Download Mode hinbekommen :)
     
    #16 Querkopf, 18. Nov. 2010
    Zuletzt bearbeitet: 18. Nov. 2010
  17. Joschi1984

    Joschi1984 Neues Mitglied

    Registriert seit:
    6. März 2009
    Beiträge:
    25
    Zustimmungen:
    0
    Hallo habe die i9000bujp5 firmware drauf welchen mod muss ich dafür laden?
     
  18. logofreax

    logofreax Gründer

    Registriert seit:
    21. Apr. 2006
    Beiträge:
    42.420
    Zustimmungen:
    1.039
    Mit dem Link im ersten Beitrag kommt du direkt zum Thread bei xda.

    Allerdings gibt es dort noch keinen Mod für die JP5 :(
     
  19. intenso80

    intenso80 VIP Mitglied

    Registriert seit:
    6. Jan. 2010
    Beiträge:
    1.097
    Zustimmungen:
    1
    hallo

    hat denn jemand bereits bei der JPP den akku mod probiert?
    welche modversion habt ihr dabei verwendet?
    ich hab jetzt die JPM und JPO probiert, ohne erfolg.
     
  20. logofreax

    logofreax Gründer

    Registriert seit:
    21. Apr. 2006
    Beiträge:
    42.420
    Zustimmungen:
    1.039
    Die aus dem Beitrag #1 sind für die aktuellen Firmewares nicht mehr geeignet.

    Mittlerweile ist der Thread dort mit über 100 Seiten derart unübersichtlich, das man nichts mehr findet.

    Alles was ich so auf die Schnelle gesehen habe wird nicht mehr weiter entwickelt "discontinued" :(
     
Die Seite wird geladen...