N900 Eine Sammlung an möglichen Beiträgen mit sinnvollem Inhalt zum Thema Nokia N900

Dieses Thema im Forum "Nokia Forum" wurde erstellt von Caffeineshock, 22. Apr. 2011.

  1. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.566
    Zustimmungen:
    40
    Und damit man sich vorstellen kann, wie mein N900 ausschaut hab ich mal ein Bild angehangen.

    *Schnell duck, versteck, wegzieh, auswander und wegrenn*
     

    Anhänge:

  2. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    hast es eine toilette, die aus rasierklingen und 30% salzsäure besteht durchgejagt, danach auf ein lkw geschmissen und mit einem ice drübergefahren? eig. sind die folgen dessen harmlos im vergleich zu dem, was icha uf dem bild sehe, den zu dem photo fallen mir keinerlei erklärungen ein, ausser, dass es im tschernobil-kraftwerk lag, als dieses explodierte, was geschichtlich gesehen nicht möglich ist. lol
    (sowas fällt mir aber auch nur ein, wenn ich besoffen bin XD prost)
     
  3. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Prosit.
    Und einen schönen Tag.

    @prot
    :eek:
     
  4. linuxelo

    linuxelo VIP Mitglied

    Registriert seit:
    11. Sep. 2008
    Beiträge:
    4.300
    Zustimmungen:
    0
    Prot: :eek:, als du es mir gezeigt hast, hatte es nur ufm Display die zwei schwarzen punkte alles andere war wie nagelneu :rolleyes:

    :abgelehnt:

    mfg
     
  5. Protector

    Protector VIP Mitglied

    Registriert seit:
    7. Apr. 2007
    Beiträge:
    14.566
    Zustimmungen:
    40
    True...Man will es kaum glauben, aber des nur simple Staubabschürfungen. Hatte es zusammen mit dem Milestone in der Tasche und musste Rasen mähen. Es war aber so heiß, dass es Haufen Staub aufgewirbelt hat. Und wie des eben so ist, reiben beide Telefone aneinander. Und komischerweise sah des N900 danach so aus und des Milestone hat keinen einzigen Kratzer.

    Da war ich ehrlich gesagt schon bisschen erstaunt. Egal, des wird repariert und gut :)
     
  6. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    proti, proti :alright:
    Also ich kannte bislang auch nur die 2-Punkt Version. Aber mit der Erklärung nachzuvollziehen :banging:

    Nur gut, dass du noch nicht gewechselt hattest. Aber jetzt hast du ja wirklich einen Grund ;)

    --- Edit ---

    Waynes interessiert:

    Ich boote jetzt mit 3 OS:
    Maemo (stock kernel, power kernel v47, pk47 mit u-boot),
    NitDroid (auf 2GB SD, oder wahlweise auf eMMC),
    MeeGo auf 4GB SD.

    Dazu chroote ich noch Easy Debian (quasi als viertes OS).

    Wollte das nur mal kurz loswerden ;)


    P.S.: es gibt auch noch die Möglichkeit kubuntu (armel) auf eine 8GB SD zu packen und dies auch noch als eigenständiges OS zu booten. Aber das ist langsam und nur als "ich-bin-Nerd-und-mach-das-weil-ich-kann" einzustufen und nicht wirklich effektiv nutzbar (da nehm ich lieber chrooted EasyDebian).
     
    #166 peterleinchen, 17. Juli 2011
    Zuletzt bearbeitet: 17. Juli 2011
  7. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
  8. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    achd us cheise ist es viel zu lesen....
    habs jezt mal schnell überflogen. muss es ganz lesen^^ aber wie ich verstanden habe auf die schnelle machen die das über ne software?
     
  9. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Wieso viel? ;)
    Sind doch exakt 2 (3) Beiträge.

    Der dritte nur als (interesaanten) Zusatz und für den richtigen link für charge21.sh
     
  10. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    verstehe aber nicht, wie das ding es macht...
    habs jezt durchgelesen, bin der englischen sprache entwede rnicht mächtig genug oder zu stur es zu begreifen.... *nochmal durchles*
     
  11. Rudei

    Rudei VIP Mitglied

    Registriert seit:
    23. Apr. 2008
    Beiträge:
    127
    Zustimmungen:
    0
    Das sieht ziemlich tricky aus iwie. Ich habs jetzt nur mal überflogen und ich glaube dass dieses Script den BME-Chip neu konfiguriert, damit er im Hostmode den Akku laden kann (natürlich mit dem entsprechendem Kabel). Hab da letztens auf TMO schon mal was im Batterie-Test-Thread gelesen. Da hat auch jemand n Script geschrieben, damit man den LadeChip des N900 neu kalibrieren kann, damit es genauere Akku-Werte liefern kann

    Edit: Ich kann natürlich auch totalen Stuss labern und das stimmt alles überhaupt ned. Wie gesagt, habs nur kurz überflogen da mir der Nokia ServicePoint letztens das falsche Hostkabel verkauft hat. Das passt nicht in die Buchse meines N900 und muss erst mim Dremel n wenig bearbeitet werden^^
     
  12. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    so in etwa hab ich das auch verstanden, doch musste es falsch sein, dachte ich, da usbhost + laden ja eigentlich nicht geht
    also, ich verstehs noch net so ganz wie das (technisch) funktionieren soll, da das nokia ja während es hostet ja strom abgibt, da kann es ja net knallhart irgendwo auch welchen abziehen. oder sind meine elektro-kenntnisse zu gering?
     
  13. Russe89

    Russe89 VIP Mitglied

    Registriert seit:
    10. Apr. 2009
    Beiträge:
    1.006
    Zustimmungen:
    6
    USB hat zwei stromkreise, einmal für die Daten, und einmal für die Bereitstellung der Funktionen, aufgeladen wird das Handy ohne Datenverkehr, wenn man dann einstellt, das das Handy nur den Datenverkehr nutzt, ist die zweite Leitung für das Aufladen frei, es muss aber auch eine Spannung für die gegenseite gegeben sein, ich weiß jetzt nicht wie ich das richtig erklären soll :p

    aber ich versuchs mal:
    Anmerkung: USB benutzt soweit ich weiß 4 pinne, diese sind durch ein o gekennzeichnet
    Code:
             USB Gerät (festplatte,maus...)
    ,-------o   5V  o-------,
    |  ,----o Daten o---,   |
    |  |                |   |
    |  |      kabel     |   |
    |  |                |   |
    |  |                |   |
    |  '----o Daten o---'   |
    '-------o   5V  o-------'
            Handy
    
    Wenn man aber jetzt hingeht, und die 5V leitung freilässt, kann das Handy über diese geladen werden.

    Hoffe das ist halbwegs verständlich^^

    Russe
     
  14. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    geht es wirklich? dass es mit 4 verschiedenen oins etc. ist ist klar.
    aber dass die 2 stromkreise verschieden gepolt werden könnten, wusst ich net
    die frage bleibt:
    wie kannst du was anschließen und gleichzeitig laden? sprich, wie soll das von den anschlüssen her funktionieren?
    schau, dass ich mal n schaltplan für zusammenstelle
     
  15. Russe89

    Russe89 VIP Mitglied

    Registriert seit:
    10. Apr. 2009
    Beiträge:
    1.006
    Zustimmungen:
    6
    Realisiert wird das ganze mit einem Y-Kabel, links oben zb an dein USB gerät, rechts oben nur die 5V von der Steckdose, unten das Handy ;)

    Russe

    /PS: Tjoa es muss wohl funktionieren wenn das jemand geschafft hat oder? *grins*

    /Edit: Was heißt verschieden gepolt? die Polung bleibt die selbe, es wird nur eingestellt, ob die 5V schiene als eingang(Laden) oder ausgang(Host) genutzt wird..
     
  16. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Also erstmal Danke russe :)

    Daten und Laden ist Standard, schließ einfach mal das N900 an den PC an: du hast Datenverkehr UND Ladung. Leistung (500mA) wird vom Port des PC bereitgestellt.
    Ist das N900 im Hostmode, gibt es bei Bedarf auch Strom ab (max. 300 oder auch nur 200 mA). Normal kannst du jetzt nicht laden. Dafür ist jetzt aber das charge21 script da, dies ermöglicht überhaupt erst, in diesem Zustand laden zu können. Dafür muss natürlich von irgendwo Strom her, dies wird durch ein 'handelsübliches' Y-Kabel (AM/AM - AF) ermöglicht. Ein M geht in einen Wallcharger (oder USB-Port), ein M mit Adaptern in unser N900 und das F für das Gerät.
    Ich hoffe, das war verständlich und richtig (ist spät) ;)
    Haben Joerg und Estel aber auch so erklärt und vor allem bewiesen. Noch Fragen? :)
     
  17. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    So. jetzt nach langer Flaute hier bei uns, mal eine ziemlich abgedriftete Frage. Die zwar ziemlich tief ins Linux greift, aber vielleicht auch nur aufs Maemo zurückzuführen ist


    Ich hätte da nämlich mal 'ne Frage bzgl. Upstart (hier für Maemo, ein Debian Ableger).
    Ich möchte ein Skript in /etc/event.d packen (Name myscript), welches mir mit Zeitversatz zyklisch eine Aufgabe erledigt, in der Art von:
    Code:
    description "test to check deactivation after reboot"
    
    author "peterleinchen"
    
    start on started hildon-desktop
    stop on stopping hildon-desktop
    
    console output
    respawn
    
    
    pre-start script
    echo pre-start `date` >> /home/user/.out
    sleep 25
    echo pre-start end  `date` >> /home/user/.out
    end script
    
    post-start script
    echo post-start `date` >> /home/user/.out
    sleep 3
    echo post-start end  `date` >> /home/user/.out
    end script
    
    pre-stop script
    echo pre-stop `date` >> /home/user/.out
    sleep 3
    echo pre-stop end  `date` >> /home/user/.out
    end script
    
    post-stop script
    echo post-stop `date` >> /home/user/.out
    sleep 3
    echo post-stop end  `date` >> /home/user/.out
    end script
    
    
    script
    while true
    do
      echo do `date` >> /home/user/.out
      sleep 1
      echo dodo `date` >> /home/user/.out
    done
    echo done `date` >> /home/user/.out
    end script
    
    Der script Part selber läuft einwandfrei und auch mit 'sudo start myscript' läuft es und gibt mir den richtigen output.
    Aber bei einem boot/reboot komme ich nur zu einer Laufzeit von ca. 30 Sekunden, dann stirbt es. Gibt es da irgend einen WD, der da rein haut? Und kann ich den abstellen?
    Ach so, noch was: den Inhalt des script Parts in eine eigene shell Datei verpackt und dieses mit exec myAusgelagertesScript aufgerufen führt auch zum Absterben. Wobei der manuelle Aufruf mit 'sudo start myscript' wiederum auch funktioniert.
    Hätte das aber gerne nach einem Boot automatisch am Laufen...


    --edit
    Ich hab mal ein kleines Test script oben reingepackt. Und dessen output:
    Code:
    ~ $ cat .out
    pre-start Mon Nov 7 00:05:52 CET 2011
    pre-start end Mon Nov 7 00:06:17 CET 2011
    post-start Mon Nov 7 00:06:17 CET 2011
    do Mon Nov 7 00:06:17 CET 2011
    dodo Mon Nov 7 00:06:18 CET 2011
    do Mon Nov 7 00:06:18 CET 2011
    dodo Mon Nov 7 00:06:19 CET 2011
    do Mon Nov 7 00:06:19 CET 2011
    post-start end Mon Nov 7 00:06:20 CET 2011
    post-stop Mon Nov 7 00:06:20 CET 2011
    post-stop end Mon Nov 7 00:06:23 CET 2011
    
    Man sieht also, dass es exakt nach 28 Sekunden hart beendet wird.
    Aber nicht von mir! Wieso? Ich peil das nicht ....


    --edit
    Selbstlösung:
    Ja, gibt so 'ne Art syslog bei Maemo. Heißt als Paket aber sysklogd, installiert sysklogd und klogd (und libc6).
    Das mit der log-priority muss aber nach jedem Boot neu gesetzt werden (oder in den kernel settings/options ?häh? gesetzt werden). Mit ein bißchen Fingerspitzengefühl einfach ins pre-start script an den Anfang gesetzt und voila.
    Jetzt habe ich den output, alle events und state changes und ein "goal changed from start to stop". Daraus gefolgert, dass dies ein normaler Vorgang ist und mir nochmal die trigger angeschaut
    Code:
    start on started hildon-desktop
    stop on stopping hildon-desktop
    
    Damit wird mein script nach dem desktop gestartet, was ich so haben will. Und anhalten sollte er mit Beendigung des Desktops, also meines Wunsches nach mit dem shutdown.
    Aber man sollte sich die gewählten Trigger -und vor allem deren Herkunft- genau anschauen/auswählen.
    So sieht der job hildon-desktop aus:
    Code:
    description "Fake job for hildon-desktop"
    author "Pekka Lundstrom <pekka.lundstrom@nokia.com"
    console none
    
    start on XSESSIONS_STARTING
    stop on stopped xsession
    
    pre-start script
        [ -e /tmp/ACT_DEAD ] && exit 1
    
        while [ ! -e /tmp/hildon-desktop/desktop-started.stamp ]
        do
            sleep 2
        done
        # This is to make sure it's really functional by the time user
        # gets to use it.
        sleep 5
    end script
    
    Ohne main script/exec wird der Status direkt auf stopped durchgesetzt und damit mein job angetriggert.

    Einfach den Trigger
    Code:
    stop on stopping hildon-desktop
    
    in
    Code:
    stop on starting shutdown
    
    geändert und alles ist gut!

    Hätte man mir auch früher sagen können ;)
    Dank an proti für den Tipp mit syslog. :)
     
    #177 peterleinchen, 5. Nov. 2011
    Zuletzt bearbeitet: 8. Nov. 2011
  18. Caffeineshock

    Caffeineshock Neues Mitglied

    Registriert seit:
    16. Feb. 2009
    Beiträge:
    211
    Zustimmungen:
    0
    sry @peter, dass ich dein thema unterbreche
    wie schaut es eigentlich damit aus, dass nokias recht spruchsvoll sind was ladestrom und -spannung angeht
    ich habe keine ahnung warum, aber nokias laden nich an 230V-> USB 5V netzteilen. es passiert nichts, wenn man sie ansteckt. das n900 leutet aber auf, wenn man es wieder abzieht
    nochwas: habe mir mal ein mobiles ladegerät zusammengebaut: 3v->5v. sämtliche geräte haben über den usb port den ich angeschlossen habe geladen: meine e-zigarette, sämtliche anderen händys wie z.b. htc's aber mein n900 nicht
    hierbei betrug die ladespannung 4,8-5,2V und das gerät lieferte mehr als genug strom (weis leider nichtmehr wie viel, doch mehr als ausreichend)
    hat wer ne ahnung was da los ist?
     
  19. peterleinchen

    peterleinchen VIP Mitglied

    Registriert seit:
    27. Juni 2009
    Beiträge:
    1.556
    Zustimmungen:
    3
    Ja klar, wochenlang geht hier nichts und dann gleich mein Thema unterbrechen :rolleyes:
    Aber egal, ist nicht schlimm. Ich hab übrigens oben noch aml ein Test script und denoutput editiert..
    Wäre ggfs. nett, wenn das mal einer auf seinem ausprobiert, ob er das gleiche Phänomen hat. Mittlerweile glaube ich alles, sind ja alles Unikate, quasi. :)
    Das ist nicht gefährlich und passiert auch nichts. Einfach als root nach /etc/event.d kopieren.
    --edit
    Hat sich erledigt, siehe oben.

    Zu deiner Frage meine ich mal was im TMO gelesen zu haben, bin mir aber nicht mehr sicher, also bitte nicht steinigen.
    Es könnte am Kabel und fehlenden USB-Adern liegen.
     
    #179 peterleinchen, 7. Nov. 2011
    Zuletzt bearbeitet: 8. Nov. 2011
  20. McLovin

    McLovin Top-Supporter

    Registriert seit:
    11. Jan. 2009
    Beiträge:
    730
    Zustimmungen:
    3
    Soooo.... melde mich mal wieder zu Wort! :)
    Oje... ist ja extrem still hier drin...

    Wie sieht's momentan mit euren N900s aus? Irgendwelche neuen Moddings probiert?

    Oh mann... ohne die "Präfix-Funktion" hätte ich niemals mehr Beiträge gefunden...

    Grüße
     
Die Seite wird geladen...