Eigene und TomTom /Garmin POIs in WeTravel nutzen

Dieses Thema im Forum "Handynavigation / GPS Logging / Tracking / Caching" wurde erstellt von Remotiv, 18. Feb. 2010.

  1. Remotiv

    Remotiv VIP Mitglied

    Registriert seit:
    19. Apr. 2009
    Beiträge:
    571
    Zustimmungen:
    0
    WeTravel ist in der Lage eigene POIs und die von Garmin oder TomTom zu nutzen.

    (Die POIs von TomTom machen derzeit noch Probleme und konnten von mir noch nicht dargestellt werden (27.02.10)
    Trotzdem hier eine Erklärung für beide (Garmin + TomTom POIs)

    Grundsätzliches zu POIs:

    Wenn man Menü > Einstellungen > erweitert > POIs wählt, stehen zunächst alle verfügbaren POI Gruppen zur Auswahl. Hier kann man alle oder einzelne Gruppen anwählen. Wenn man welche aktiviert hat, muss man Option > ok klicken. Jetzt kommt man zu den POI Typen. (kann ein paar Sekunden dauern bis die Liste angezeigt wird) Die Liste beinhaltet alle POIs die sich unter den vorher ausgewählten Gruppen befinden. Hier kann man die einzelnen POIs aktivieren oder deaktivieren.

    So gehts für Garmin oder TomTom POI:

    Die von Garmin hab ich getestet und funktionieren. Bitte die "dir" Datei im TTPOI Ordner lesen.

    Die POIs von Garmin kann man hier runter laden. (teilweise kostenlos) http://www.pocketnavigation.de/poi/overlays/5.6.74.html

    Garmindatei z. B. Aldi-Nord.csv + Aldi-Nord.png (*.csv und *.png Datei MÜSSEN den gleichen Namen haben) in den TTPOI Ordner von WeTravel packen.
    (WeTravel erkennt NUR *.png Bilder. Daher müssen die runter geladenen POI Bilder erst in *png umgewandelt werden.)

    Aktivieren: Menü > "Einstellungen" > "erweitert" > "POIs" und dort "TomTom" markieren, > "option" > "ok"

    Jetzt wird in der POI Typ Liste "Aldi-Nord.csv" angezeigt. Dieses markieren und "Optionen" > "ok" klicken.

    Nach kurzer Zeit werden alle von TomTom erfassten Aldi-Nord Filialen angezeigt.

    !!!Achtung: Genutzte POIs in den TTPOI Ordner verlangsamen das Programm erheblich, da zusätzliche Rechenleistung nötig ist. Beim Neustart kann es "einfrieren", wenn zu viele TTPOIs aktiviert sind!!!

    Getestet auf dem Sony Ericsson W995 mit der "Germany_OSM_241209" Karte, die man hier bekommt: WeTravel Karte Deutschland Dezember 2009

    So gehts für OpenStreetMap POI:

    Die POIs sind auf open street maps bereits gekennzeichnet.

    Es fehlen also nur noch die entsprechenden Bildchen.
    Eine bereits erstellte WeTravel POI Sammlung bekommt man hier: 313 POI für WeTravel
    Wenn man diese POIs nutzt, kann man einige POIs aktivieren, ohne dass das Programm erheblich verlangsamt.

    Eigene POIs erstellen

    Beispiel:

    Erstelle ein Bild in 20x20 Pixel auf dem die Buchstaben "WC" dargestellt sind und speichere es als png ab. (WC.png)

    Öffne den Maps Ordner von WeTravel und den Ordner mit der geladenen Karte (da wo die 1,2,3,4 ... Dateien drin sind)

    Öffne POIConfig mit dem Windows Editor

    Ergänze folgendes:
    poitypename_81 : amenity-toilets
    typegroup_81 : 1
    image_81 : WC.png

    speichern

    Füge das Bild mit dem "WC" in den Ordner mit der geladenen Karte. (zu 1,2,3,4....... )
    Hier kommen alle POI *.png Bilder rein und die POIConfig Datei. (Wenn du die Karte wechselst musst du auch die POIs in die andere Karte übertragen)

    Starte WeTravel neu

    dann: Menü > Einstellungen > erweitert > POIs

    Hier die POI Gruppe auswählen, für die du das Bild gemacht hast. In diesem Beispiel also "amenity"

    Option > ok > In der POI-Typ Liste jetzt "amenity-toilets" markieren
    dann Option > ok.

    Folgende Einstellung ebenfalls kontrollieren:
    Menü - Einstellungen - Erweitert - Anzeige - POI-Symbole anzeigen aktivieren (wer keine Symbole möchte sondern einen Schriftzug des POI, muss POI-Namen anzeigen aktivieren. Hier wird dann auch genau angezeigt, worum es sich handelt) dann Option - Ok.

    WeTravel neu starten und das Symbol zeigt alle auf der open street map eingebetteten Toiletten.

    Prost
     
    #1 Remotiv, 18. Feb. 2010
    Zuletzt bearbeitet: 14. Apr. 2010
  2. nilsxvx94

    nilsxvx94 Neues Mitglied

    Registriert seit:
    4. Feb. 2010
    Beiträge:
    10
    Zustimmungen:
    0
    Bei mir läuft ja zum glück We Travel.
    Ich wollte fragen wie man bei We Travel die sogenannten POIs einfügen kann und wo man diese her bekommt.
     
  3. hasi58

    hasi58 Neues Mitglied

    Registriert seit:
    29. Nov. 2006
    Beiträge:
    10
    Zustimmungen:
    0
    Im Menue - Einstellungen - Erweitert --den Punkt POIs anwählen und aussuchen........POIs sind im Mapordner der Karten enthalten.


    Achtung = Man(n) kommt aus dem Menuepunkt POIS nur über "Optionen" ----zurück ----- raus.



    Hasi
     
    #3 hasi58, 19. Feb. 2010
    Zuletzt bearbeitet: 19. Feb. 2010
  4. skone

    skone Neues Mitglied

    Registriert seit:
    22. Feb. 2010
    Beiträge:
    1
    Zustimmungen:
    0
    Hallo Leute,
    wollte mal fragen, wie man TomTom Pois in die Karte integriert? Habe eine .cv2 und eine gleichnamige .png Datei. Habe ich von Pocketnavigation runtergeladen. Mein Jet will mir diese aber nicht anzeigen. Warum? Wie funktionierts genau?
     
  5. logofreax

    logofreax Gründer

    Registriert seit:
    21. Apr. 2006
    Beiträge:
    42.420
    Zustimmungen:
    1.039
    #5 logofreax, 24. Feb. 2010
    Zuletzt bearbeitet: 1. März 2010
  6. janemann

    janemann Neues Mitglied

    Registriert seit:
    6. Sep. 2009
    Beiträge:
    3
    Zustimmungen:
    0
    Hab jetzt die besagten POI´s (ALDI) eingefügt, aber er zeigt sie mir nicht an. Muss ich da noch etwas einstellen?

    Gruß janemann
     
    #6 janemann, 26. Feb. 2010
    Zuletzt von einem Moderator bearbeitet: 27. Feb. 2010
  7. Remotiv

    Remotiv VIP Mitglied

    Registriert seit:
    19. Apr. 2009
    Beiträge:
    571
    Zustimmungen:
    0
    @janemann:

    Wenn du ein Garmin POI Bild (*.png) und die dazugehörige *.csv Datei in den TTPOI Ordner gepackt hast, musst du den POI noch aktivieren, unter ...

    Menü > Einstellungen > erweitert > POIs > unter "POI Gruppe" dann "TomTom" markieren > Optionen > Ok (etwas warten), springt weiter zu POI-Typ, dann Aldi markieren > Optionen > ok (etwas warten, Karte wird angezeigt und nach ca. 5 Sek (handyabhängig) auch Aldi.
     
    #7 Remotiv, 26. Feb. 2010
    Zuletzt von einem Moderator bearbeitet: 27. Feb. 2010
  8. PolytroX

    PolytroX Neues Mitglied

    Registriert seit:
    17. Okt. 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Leider haut das bei mir nicht hin. Ich habe es mal mit BurgerKing getestet. Dabei habe ich die "D-BurgerKing.csv" runter geladen und eine passende "D-BurgerKing.png" erstellt. Wie beschrieben habe diesen POI auch aktiviert und er wird bei WeTrevel auch in der Liste angezeigt. Den Haken habe ich ebenfalls gesetzt. Trotzdem Wird der POI nicht angezeigt.

    In der "D-BurgerKing.csv" ist der POI für dieses BürgerKing auch eingetragen, siehe Bild

    [​IMG]

    Kann mir bitte Jemand erklären, warum es nicht angezeigt wird?
     
  9. Remotiv

    Remotiv VIP Mitglied

    Registriert seit:
    19. Apr. 2009
    Beiträge:
    571
    Zustimmungen:
    0
    Hast du bereits andere csv Dateien getestet, um auszuschließen, dass es an dieser Datei liegt?
    Schau mal nach, ob der Burger King an anderer Adresse zu finden ist.
    Hast du einen Neustart gemacht?
    Es wäre sinnvoll alle anderen POIs, sowohl andere csv Dateien, als auch die WeTravel eigenen POIs Bilder /POIs Beschreibungen erstmal auszuschalten, um Performance Probleme auszuschließen.
    Ich habe die csv Dateien am W995 getestet. Man muss in Betracht ziehen, dass es ggf. an deiner Firmware liegt.
    Wo hast du die csv Datei her? Wenn sie kostenlos ist, könntest du den link angeben, dann teste ich sie auf meinem Handy.
     
  10. PolytroX

    PolytroX Neues Mitglied

    Registriert seit:
    17. Okt. 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Ja, habe ich mit Aldi ebenfalls getestet. Wurde ebenfalls nicht angezeigt. Was mich ebenfalls wundert ist die Tatsache, daß nach dem demarkieren aller überflüssigen Poi Kategorien alle wieder markiert sind, wenn ich erneut in die POI Option gehe. Die Rechte auf für WeTrevel habe ich auf meinem M8800 Pixon gesetzt (erlaubt). WeTrevel + Handy habe ich neu gestartet. Leider ohne Erfolg. Meine Firmware: "M880BXXJA2 Januar 2010 rev2" habe ich von hier.
     
  11. Remotiv

    Remotiv VIP Mitglied

    Registriert seit:
    19. Apr. 2009
    Beiträge:
    571
    Zustimmungen:
    0
    Springt das Programm denn nach Abschluss der POI Einstellungen selbständig wieder zurück zur Karte?
     
  12. PolytroX

    PolytroX Neues Mitglied

    Registriert seit:
    17. Okt. 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Ja, das tut es.
     
  13. Remotiv

    Remotiv VIP Mitglied

    Registriert seit:
    19. Apr. 2009
    Beiträge:
    571
    Zustimmungen:
    0
    Sonderbar. Das könnte an der Samsungfirmware bzw. überhaupt an Samsung. Ich bin überfragt. :-(
     
  14. PolytroX

    PolytroX Neues Mitglied

    Registriert seit:
    17. Okt. 2010
    Beiträge:
    12
    Zustimmungen:
    0
    Ich bedanke mich für die Bemühungen. Pois die über die Map eingebunden sind, werden mir alle angezeigt. Besonders viele Pois werden bei der Map "Deutschland_24.12.09" angezeigt. Leider ist diese Map sehr fehlerhaft.
    Nehme ich die Map "Deutschland 31.03.09", wird sie richtig angezeigt, aber dafür kaum Poi´s.

    Ich werde einfach damit leben und bedanke mich nochmals für die Hilfe. :)
    Vielleicht kommt bald ja eine Map heraus, die kaum Fehler hat und auch reichlich POI´s. :)
     
Die Seite wird geladen...