Xperia X10 CPU Speed beim Xperia X10 erhöhen

Dieses Thema im Forum "Sony Ericsson" wurde erstellt von Crazyschranz, 28. Sep. 2010.

  1. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    So nachdem ich mir nun die letzten Tage mal mich über die Performance vom X10 schlau gemacht hab bemerkte ich in vielen Threads das das meist nur mit 548Mhz läuft!!! Aber es kann normal ja mehr! Hier mal ein TuT wie man den Cpu Speed pushn kann und dennoch Akku spart :D

    1. Handy muss root sein!!

    2. Installation: Nach dem erfolgreichen Rooten im Market das Programm "SetCPU" herunterladen. Kostet aber ist es wert :D

    3. Nun das Programm starten und "Autodetect Speed Recommended" auswählen. Beim folgenden Popup "OK" drücken

    4. Nun im oben auf "Profil" drücken. Den Haken bei "Enable" setzten

    5.Nun auf "Add Profile" gehen und folgendes einstellen:

    Condition: Charging\Full
    Max: 998400
    Min: 998400
    Scaling: performance
    Priority: 100

    und save drücken.

    Um nun aber auch den Akku zu schonen wird noch ein Profil erstellt!

    Wieder auf "Add Profile" mit folgenden Werten:

    Condition: Screen Off
    Max: 384000
    Min: 245000
    Scaling: powersave
    Priority: 100

    und save drücken.

    Jetzt noch die letzten 30% als Notakku setzen und den stellt man wie folgt ein :

    Condition: Battery <
    Battery <: 30%
    Max 384000
    Min 245000
    Scaling powersave
    Priority 100


    Somit sollte nun im Betrieb der Cpu Speed bemerkbar sein:D

    Viel Spaß dabei

    Weder Ich noch F4M übernimmt hierfür eine Garantie!!! Alles auf eigene Gefahr.

    Bitte um Kommentare ob es bei euch auch merkbar besser geworden ist! Ich finde der Akku hebt deutlich länger und diverse Vorgänge laufen nun flüssiger!!

    Mfg Crazy
     
  2. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
    Danke.

    Werde nacher im SE Index einen Android Bereich einrichten und die Tutorials verlinken.
     
  3. riep16

    riep16 VIP Mitglied

    Registriert seit:
    3. Okt. 2009
    Beiträge:
    765
    Zustimmungen:
    0
    Danke hat echt klasse geklappt, besonders Mediascape ist jetzt schneller beim Wechsel der Startansicht zu den Alben.
     
  4. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Achja was man dazu sagen muss! Man merkt den Unterschied leider nicht bei Programmen und sonstigen was über die SD läuft!! Da das ja auf den CPU angewendet wird ist dies auf die Proggs bezogen was via System direkt laufen!

    @ riep klasse das es bei dir spürbar funktioniert! Mein Akku verbrauch ist auch enorm gesunken damit! Bisher hielt er maximal nen Tag aber nun fast 3 Tage bei selber nutzung!!
     
  5. fknpwned

    fknpwned VIP Mitglied

    Registriert seit:
    26. Apr. 2008
    Beiträge:
    9.025
    Zustimmungen:
    4
    Kann ich nur bestätigen.

    Must have App ;)
     
  6. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ich konnte keine (großen) Unterschiede feststellen.
    Allerdings habe ich bei meiner Version von "SetCPU" auch eine andere Darstellung. Ich musste die bereits vorhandenen Profile erstmal einstellen und dann konnte ich sie bearbeiten.
    Habe die App deswegen vorerst wieder installiert, ich hab sie aber noch auf der SD, damit ich sie eventuell nochmal testen kann.
     
  7. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Also Mediascape startet bei mir schon deutlich schneller und woran ich es doch merke mein Akku hält fast doppelt solang wie zuvor.
     
  8. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ich habe mir jetzt die V2.03 (neuste Version) geladen und jz kann ich auch den Speedunterschied feststellen. Danke für das Tutorial.

    Das mit dem Notakku habe ich jetzt erstmal gelassen, weil das X10 sonst bestimmt sehr langsam ist.

    Muss ich eigentlich den Hacken bei "Set on Boot" setzen? Sonst muss ich ja nach jedem Start einmal SetCPU starten, oder?
     
  9. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Hmm gute Frage mit dem Set on Boot :D Darfst du gerne testen und berichten.
    Freut mich das nen Unterschied feststellen konntest! Dann hat sich das TuT gelohnt ;)

    Das mit Notakku wirst du sehen lohnt sich ebenfalls! Zudem wenn der Screen eh aus ist (Tastensperre) brauchst ja so oder so keine Leistung warum also Akku dann verschwenden :D
     
  10. ragalthar

    ragalthar VIP Mitglied

    Registriert seit:
    26. Juni 2007
    Beiträge:
    4.042
    Zustimmungen:
    105
    Weil manche Apps im Hintergrund weiterlaufen (z.B. der Abruf der E-Mails von Google, GMX, web.de, Yahoo, etc.).
     
  11. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ich lade gerade mein X10 und dabei ist mir aufgefallen, dass es beim Laden permanent auf 998MHz lãuft. Das muss ja nicht sein und deswegen mein Tipp:
    Beim Laden das Profil "Charging/Full" deaktivieren, denn es muss ja nicht sinnlos auf 100% durchlaufen.

    Das hier ist vom X10 aus gepostet.
     
  12. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Aber stört nun auch nicht wenn es so eingestellt ist zudem viele das Gerät da auch nutzen wenn es geladen wird und in dem Fall hat man dann eben volle Leistung :D
     
  13. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ok, guter Konter xD
    Ich finde es aber besser, das Profil während es läd auszuschalten, dann geht das Laden auch schneller.
    Aber das kann ja jeder für sich entscheiden.
     
  14. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ich habe für mich jetzt eine Lösng gefunden. Anstatt das Profil immer beim Laden auszuschalten habe ich das Pofil geändert und zwar auf "Charging USB/Full". Jetzt läuft es beim Laden nomal weiter, allerdings läuft es jetzt bei der USB Verbindung auf 100%, da es aber schnelles USB hat, habe ich es nie lange angeschlossen und dann ist es egal, wenn es mal ne Weile auf 100% läuft. Wenn der Screen ausgeht wird ja eh das Powersave-Profil ausgewählt.
     
  15. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Super das hier auch Leute sich ransetzen und auch mal rumprobieren!!! Weiter so!!
     
  16. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ja :)

    Weißt du wie man das X10 auf 1000MHz übertaktet? Ich habe es bisher noch nicht herausgefunden.
     
  17. Crazyschranz

    Crazyschranz VIP Mitglied

    Registriert seit:
    17. Okt. 2009
    Beiträge:
    2.651
    Zustimmungen:
    9
    Leider noch nicht sorry aber wenn jemand was dazu findet nur her damit :D
     
  18. Flo95

    Flo95 VIP Mitglied

    Registriert seit:
    23. Sep. 2009
    Beiträge:
    514
    Zustimmungen:
    0
    Ok. Ich werde mich demnächst mal mit dem Overclock Widget beschäftigen, wenn es klappt werde ich es posten.
     
  19. krteddy

    krteddy Neues Mitglied

    Registriert seit:
    15. Sep. 2007
    Beiträge:
    67
    Zustimmungen:
    0
    Wenn du das versuchen möchtest könntest de dir ja mal die Übertaktungs-Treads vom Desire durch lesen das hat ja die gleiche CPU verbaut wie unser X10! ;)

    Hab mich da noch nicht dran getraut und nach dem ich beim versuch die Batterie Anzeige zu ändern fast mein X10 geschrottet habe bin ich noch etwas vorsichtiger geworden! :D

    Gruß TEDDY
     
  20. Bluetiger

    Bluetiger Guest

    Einfach Top ich merke den unterschied auch beim Systemstart es ist einfach viel Schneller aber gibt es denn auch eine möglichkeit den Ram so zu optimieren???

    Lg Bluetiger
     
Die Seite wird geladen...